<!DOCTYPE html>
<!--[if lt IE 7 ]><html class="ie ie6 no-js" lang="en-US"> <![endif]-->
<!--[if IE 7 ]><html class="ie ie7 no-js" lang="en-US"> <![endif]-->
<!--[if IE 8 ]><html class="ie ie8 no-js" lang="en-US"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html class="no-js" lang="en-US"> <!--<![endif]-->
<head>

<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<!--[if lt IE 9]>
    <script src="https://www.bcheights.com/wp-content/themes/citynews/js/html5shiv.js" type="text/javascript"></script>
    <![endif]-->

<meta name="author" content="Katherine Caniff">


<script data-cfasync="false">
		(function(ac) {
			var d = document, s = 'script', id = 'adplugg-adjs';
			var js, fjs = d.getElementsByTagName(s)[0];
			if (d.getElementById(id)) return;
			js = d.createElement(s); js.id = id; js.async = 1;
			js.src = '//www.adplugg.com/apusers/serve/' + ac + '/js/1.1/ad.js';
			fjs.parentNode.insertBefore(js, fjs);
		}('A4821759'));
	</script>


<title>Writer Bridgett Davis Discusses Mother’s Legacy in Memoir - The Heights</title>
<meta name="description" content="Writer Bridgett Davis sat down with BC professor Angela Ards to discuss her new memoir that details the remarkable working life of her mother." />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Writer Bridgett Davis Discusses Mother’s Legacy in Memoir - The Heights" />
<meta property="og:description" content="Bridgett Davis discusses her mother&#039;s enduring legacy in her talk with BC professor Angela Ards." />
<meta property="og:url" content="https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" />
<meta property="og:site_name" content="The Heights" />
<meta property="article:publisher" content="https://www.facebook.com/TheHeights" />
<meta property="article:published_time" content="2020-11-03T05:32:26+00:00" />
<meta property="article:modified_time" content="2020-11-03T05:32:27+00:00" />
<meta property="og:image" content="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg" />
<meta property="og:image:width" content="768" />
<meta property="og:image:height" content="433" />
<meta property="fb:app_id" content="544269992416280" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Writer Bridgett Davis Discusses Mother’s Legacy in Memoir - The Heights" />
<meta name="twitter:description" content="Bridgett Davis discusses her mother&#039;s enduring legacy in her talk with BC professor Angela Ards." />
<meta name="twitter:image" content="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg" />
<meta name="twitter:creator" content="@BCheights" />
<meta name="twitter:site" content="@BCheights" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.bcheights.com/#organization","name":"The Heights","url":"https://www.bcheights.com/","sameAs":["https://www.facebook.com/TheHeights","https://www.instagram.com/bcheights/","https://twitter.com/BCheights"],"logo":{"@type":"ImageObject","@id":"https://www.bcheights.com/#logo","inLanguage":"en-US","url":"","caption":"The Heights"},"image":{"@id":"https://www.bcheights.com/#logo"}},{"@type":"WebSite","@id":"https://www.bcheights.com/#website","url":"https://www.bcheights.com/","name":"The Heights","description":"The Independent Student Newspaper of Boston College","publisher":{"@id":"https://www.bcheights.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.bcheights.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#primaryimage","inLanguage":"en-US","url":"https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg","width":768,"height":433},{"@type":"WebPage","@id":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#webpage","url":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/","name":"Writer Bridgett Davis Discusses Mother\u2019s Legacy in Memoir - The Heights","isPartOf":{"@id":"https://www.bcheights.com/#website"},"primaryImageOfPage":{"@id":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#primaryimage"},"datePublished":"2020-11-03T05:32:26+00:00","dateModified":"2020-11-03T05:32:27+00:00","description":"Writer Bridgett Davis sat down with BC professor Angela Ards to discuss her new memoir that details the remarkable working life of her mother.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/"]}]},{"@type":"Article","@id":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#article","isPartOf":{"@id":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#webpage"},"author":{"@id":"https://www.bcheights.com/#/schema/person/f670410c98fccad6b90a348ae73906f7"},"headline":"Writer Bridgett Davis Discusses Mother\u2019s Legacy in Memoir","datePublished":"2020-11-03T05:32:26+00:00","dateModified":"2020-11-03T05:32:27+00:00","mainEntityOfPage":{"@id":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#webpage"},"commentCount":0,"publisher":{"@id":"https://www.bcheights.com/#organization"},"image":{"@id":"https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#primaryimage"},"keywords":"angela ards,bridgett davis","articleSection":"Arts,On Campus,Review","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/#respond"]}]},{"@type":"Person","@id":"https://www.bcheights.com/#/schema/person/f670410c98fccad6b90a348ae73906f7","name":"Katherine Caniff","image":{"@type":"ImageObject","@id":"https://www.bcheights.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/?s=96&d=mm&r=g","caption":"Katherine Caniff"}}]}</script>

<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Heights &raquo; Feed" href="https://www.bcheights.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Heights &raquo; Comments Feed" href="https://www.bcheights.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Heights &raquo; Writer Bridgett Davis Discusses Mother’s Legacy in Memoir Comments Feed" href="https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/feed/" />

<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.2.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-37006610-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-37006610-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bcheights.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sb_instagram_styles-css' href='https://www.bcheights.com/wp-content/plugins/instagram-feed/css/sb-instagram-2-2.min.css?ver=2.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.bcheights.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.bcheights.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='molongui-authorship-css' href='https://www.bcheights.com/wp-content/plugins/molongui-authorship-pro/public/css/molongui-authorship-pro.7857.min.css?ver=1.0.7' type='text/css' media='all' />
<style id='molongui-authorship-inline-css' type='text/css'>
:root{ --m-a-box-bp: 600px; --m-a-box-bp-l: 599px; }
</style>
<link rel='stylesheet' id='dntplgn_style-css' href='https://www.bcheights.com/wp-content/plugins/recurring-donation/css/style.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='jquery_ui_style-css' href='https://www.bcheights.com/wp-content/plugins/recurring-donation/css/jquery-ui-styles.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-default-fonts-css' href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C600%2C700%2C900%2C400italic%2C600italic%2C700italic%2C900italic%7CPT+Serif%3A400%2C700%2C400italic%2C700italic%7CRoboto+Slab%3A400%2C700%2C300%2C100%7CVoltaire&#038;subset=latin%2Clatin-ext%2Cvietnamese%2Ccyrillic-ext%2Ccyrillic%2Cgreek%2Cgreek-ext' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-style-css' href='https://www.bcheights.com/wp-content/themes/theheights/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://www.bcheights.com/wp-content/themes/citynews/assets/css/font-awesome/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-css' href='https://www.bcheights.com/wp-content/themes/citynews/build/citynews.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-custom-fonts-css' href='https://fonts.googleapis.com/css?family=Adamina%3A400%2C700%2C400italic%2C700italic%7CAlike%3A400%2C700%2C300%2C100&#038;subset=latin%2Clatin-ext%2Cvietnamese%2Ccyrillic-ext%2Ccyrillic%2Cgreek%2Cgreek-ext' type='text/css' media='all' />
<link rel='stylesheet' id='bb-css-css' href='https://www.bcheights.com/wp-content/plugins/bb_footer_builder/bestbugcore//assets/css/style.css?ver=1.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='bbfb-css' href='https://www.bcheights.com/wp-content/plugins/bb_footer_builder//assets/css/bbfb.css?ver=1.8.9' type='text/css' media='all' />
<style id='bbfb-inline-css' type='text/css'>
#bb-footer-inside-footer .bb-footer-inside { max-width: 1170px; }
</style>
<link rel='stylesheet' id='citynews-addon-css' href='https://www.bcheights.com/wp-content/plugins/citynews-addon/assets/css/citynews-addon.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-child-style-css' href='https://www.bcheights.com/wp-content/themes/theheights/style.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.bcheights.com/wp-content/themes/theheights/style.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='olympus-google-fonts-css' href='https://fonts.googleapis.com/css?family=Quattrocento+Sans%3A400%2C400i%2C700%2C400ii%2C700i%7CArbutus+Slab%3A400%2C400i&#038;display=swap&#038;ver=2.2.4' type='text/css' media='all' />
<style id='olympus-google-fonts-inline-css' type='text/css'>

	:root {
		--font-base: ;
		--font-headings: ;
		--font-input: ;
	}
	
</style>
<link rel='stylesheet' id='jetpack_css-css' href='https://www.bcheights.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.bcheights.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/out\\\/\",\"label\":\"Affiliate\"}]","home_url":"https:\/\/www.bcheights.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.2.2' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4' id='jquery-ui-widget-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/recurring-donation/js/script.js?ver=5.5.3' id='dntplgn_script-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/themes/citynews/assets/js/modernizr.custom.41385.js' id='modernizr-custom-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/themes/citynews/assets/js/jflickrfeed.min.js' id='jflickrfeed-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/themes/citynews/assets/js/jquery.colorbox.js' id='colorbox-js'></script>
<link rel="https://api.w.org/" href="https://www.bcheights.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.bcheights.com/wp-json/wp/v2/posts/184692" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bcheights.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bcheights.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://www.bcheights.com/?p=184692' />
<link rel="alternate" type="application/json+oembed" href="https://www.bcheights.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.bcheights.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F&#038;format=xml" />

<style type="text/css">
/* Add your CSS code here.

For example:
.example {
    color: red;
}margin: 20px;
    text-align: center;



For brushing up on your CSS knowledge, check out http://www.w3schools.com/css/css_syntax.asp

End of comment */ 

.mh-container .mh-widget .custom-html-widget {
   padding-inline-end: 360px;
      
   
}

</style>


<style type="text/css">
/* Add your CSS code here.
                     
For example:
.example {
    color: red;
}



For brushing up on your CSS knowledge, check out http://www.w3schools.com/css/css_syntax.asp

End of comment */ 

.page-id-134974  .entry-title {display: none;}
.page-id-134974  .entry-content h1 {font-size: 200%;}
@media (min-width:600px) {
    .page-id-134974  .entry-content  {padding-left: 20%; padding-right: 20%;}
/*
  .page-id-134974  .entry-content p, img {padding-left: 20%; padding-right: 20%;}
  .page-id-134974  .entry-content h1,h2,h3,h4,h5 {padding-left: 20%; padding-right: 20%;}
  */
  
  }</style>

<style type="text/css">
</style>
<script>
    (function(ac) {
      var d = document, s = 'script', id = 'adplugg-adjs';
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id; js.async = 1;
      js.src = '//www.adplugg.com/serve/' + ac + '/js/1.1/ad.js';
      fjs.parentNode.insertBefore(js, fjs);
    }('A4821759'));
</script>
<div class="adplugg-tag" data-adplugg-zone="top_banner"></div>
<style type="text/css">
a:active,
a:hover,
#primary_menu ul li.current-menu-item a,
#primary_menu ul li a:hover,
#breadcrumbs .goback:hover,
.channel .channel_title a,
.post .entry-title a:hover,
.post .entry-tools a:hover,
.post_list li a.post_title:hover,
#popup_window h3 a,
.entry-content a,
.comment-author a:hover,  
.comment-list .pingback a:hover,  
.comment-list .trackback a:hover,  
.comment-metadata a:hover{
	color:#0000ee;
}
.channel .channel_title a,
.tagcloud a:hover,
#popup_window .language_list li a:hover,
#popup_window .dashboard_items li a:hover,
.alaya_pagenavi span,
.alaya_pagenavi a.page:hover,
.contact-form input[type="submit"],
#topbar #tools a:hover,
.button.button-primary,
button.button-primary,
input[type="submit"].button-primary,
input[type="reset"].button-primary,
input[type="button"].button-primary{
    border-color:#0000ee;
}
.post_slider.flexslider .flex-control-paging li a.flex-active,
.post.sticky .sign,
.alaya_pagenavi span,
.alaya_pagenavi a.page:hover,
#respond input[type="submit"],
.contact-form input[type="submit"],
#topbar #tools a:hover,
.button.button-primary,
button.button-primary,
input[type="submit"].button-primary,
input[type="reset"].button-primary,
input[type="button"].button-primary{
	background-color:#0000ee;
}


h1,h2,h3,h4,h5,h6,
.post_list li a.post_title,
.pushy a{font-family:Alike,Arial, Helvetica, sans-serif;}


body,
p,
.post_navi a,
.tagcloud a{font-family:Adamina,Arial, Helvetica, sans-serif;}
</style>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<meta name="twitter:partner" content="tfwp">
<meta name="twitter:card" content="summary"><meta name="twitter:title" content="Writer Bridgett Davis Discusses Mother’s Legacy in Memoir"><meta name="twitter:description" content="Bridgett Davis discusses her mother&#039;s enduring legacy in her talk with BC professor Angela Ards."><meta name="twitter:image" content="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg">
<style type="text/css" id="wp-custom-css">
				.adplugg-tag[data-adplugg-zone="top_banner"] {
   text-align: center;
}
#bottom_widget .container .four.columns { display: none; }
#bottom_widget .container .four.columns:none { display: block; }
.sports .entry-title {
    font-size: 20px; /*Change to what you want*/
    font-weight: 400; /*Depend on the font weight choices*/
}
.right .entry-title {
    font-size: 20px; /*Change to what you want*/
    font-weight: 400; /*Depend on the font weight choices*/
}
.left .entry-title {
    font-size: 20px; /*Change to what you want*/
    font-weight:1300; /*Depend on the font weight choices*/
}

.grand-post-offset ul.post_list li:first-child{
	display: none;
}
.grand-post-offset-article .standard_blog article.thumbnail_s:first-child{
	display: none !important;
}

.grand-post-offset-secondary .wpb_wrapper .standard_blog article.thumbnail_s:first-child{
	display: none !important;
}
.ops .entry-title {
    font-size: 20px; /*Change to what you want*/
    font-weight:1300; /*Depend on the font weight choices*/
}
p {
font-size:17px;
}
.category{
	font-size: 0;
	line-height:0
}
@media only screen and (max-width: 959px)
 .logo {
    margin-top: 0;
 }
.logo a {
    width: 80%;
 }
#primary_menu ul li:last-child:after {
   display:none;
}
body{
  overflow-x: hidden;
}



/*-----fixed------------*/
/* .standard_blog > article:nth-first-child(-n+5){
	display: none !important;
} */



			</style>

<style>
		.menu, .page_item a, .menu-item a {
font-family: "Quattrocento Sans" !important;
 }
.entry-title, .entry-title a, .post-title, .post-title a, .page-title, .entry-content h1, #content h1 {
font-family: "Arbutus Slab" !important;
 }
	</style>

<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-184692 single-format-standard citynews with-sidebar wpb-js-composer js-comp-ver-6.4.1 vc_responsive">

<nav class="pushy pushy-left">
<ul>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181430"><a href="https://www.bcheights.com/coronavirus-updates-2/">Coronavirus Updates</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170476"><a href="https://www.bcheights.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170482"><a href="https://www.bcheights.com/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170521"><a href="https://www.bcheights.com/arts/">Arts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170548"><a href="https://www.bcheights.com/opinions/">Opinions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-172205"><a href="https://www.bcheights.com/metro/">Metro</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-181589"><a href="https://magazine.bcheights.com">Magazine</a></li>
</ul>
</nav>

<div class="site-overlay"></div>
<div id="body-container">

<div id="topbar">

<div class="social_icons">
<div class="social-icons clearfix">
<a href="https://www.facebook.com/theheights/" title="Facebook" class="facebook" target="_blank"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/bcheights" title="Twitter" class="twitter" target="_blank"><i class="fa fa-twitter"></i></a>
<a href="https://www.instagram.com/bcheights/" title="instagram" class="instagram" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
</div>

<div class="menu_button hide"><a href="javascript:void(0)"><i class="fa fa-bars"></i></a></div>

<div id="tools">
<a href="javascript:void(0);" class="search_btn"><i class="fa fa-search"></i></a>
</div>
</div>
<header id="top">

<div class="logo">
<a href="https://www.bcheights.com/" title="The Heights">
<span><img src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2.png" /></span>
</a>
<div class="local_info">
<span class="local_date">Tuesday 3 November 2020 </span>
<div id="weather-image"><img src="" class="weather-icon" /></div>
<div id="weather">
<span class="weather-min-temperature"></span> - <span class="weather-max-temperature"></span>
</div>
<div class="weather-location"></div>
</div>
</div>

<nav id="primary_menu">
<ul class="sf-menu">
<li id="menu-item-181430" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.bcheights.com/coronavirus-updates-2/">Coronavirus Updates</a></li>
<li id="menu-item-170476" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.bcheights.com/news/">News</a></li>
<li id="menu-item-170482" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.bcheights.com/sports/">Sports</a></li>
<li id="menu-item-170521" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.bcheights.com/arts/">Arts</a></li>
<li id="menu-item-170548" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.bcheights.com/opinions/">Opinions</a></li>
<li id="menu-item-172205" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.bcheights.com/metro/">Metro</a></li>
<li id="menu-item-181589" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://magazine.bcheights.com">Magazine</a></li>
</ul>
</nav>
</header>

<div id="cn_content" class="container row">
<div id="breadcrumbs">
<div class="navi"><i class="fa fa-home"></i><a href="https://www.bcheights.com/">Home</a> <span class="sep">&raquo;</span> <span class="current">Writer Bridgett Davis Discusses Mother’s Legacy in Memoir</span></div>
<div class="share">
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" target="_blank" class="facebook"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/share?text=Writer+Bridgett+Davis+Discusses+Mother%E2%80%99s+Legacy+in+Memoir&amp;url=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" target="_blank" class="twitter"><i class="fa fa-twitter"></i></a>
<a href="https://pinterest.com/pin/create/button/?media=https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg&amp;description=Writer+Bridgett+Davis+Discusses+Mother%E2%80%99s+Legacy+in+Memoir&amp;url=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F" target="_blank" class="pinterest"><i class="fa fa-pinterest"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;title=Writer+Bridgett+Davis+Discusses+Mother%E2%80%99s+Legacy+in+Memoir&amp;source=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F&amp;url=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F" target="_blank" class="linkedin"><i class="fa fa-linkedin"></i></a>
</div>
</div>

<div id="main" class="twelve columns">
<div class="standard_blog">

<article class="post-184692 post type-post status-publish format-standard has-post-thumbnail hentry category-arts category-on-campus category-review tag-angela-ards tag-bridgett-davis">
<div class="thumbnail"><img width="768" height="433" src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg" class="featured_image wp-post-image" alt="Writer Bridgett Davis Discusses Mother’s Legacy in Memoir" loading="lazy" srcset="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg 768w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis-300x169.jpg 300w" sizes="(max-width: 768px) 100vw, 768px" data-attachment-id="184693" data-permalink="https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/bridgettdavis/" data-orig-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg" data-orig-size="768,433" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="BridgettDavis" data-image-description="" data-medium-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis-300x169.jpg" data-large-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg" /></div>
<div class="entry-body">
<span class="category"><a href="https://www.bcheights.com/category/arts/" rel="category tag">Arts</a>, <a href="https://www.bcheights.com/category/arts/on-campus/" rel="category tag">On Campus</a>, <a href="https://www.bcheights.com/category/arts/review/" rel="category tag">Review</a></span>
<h1 class="entry-title">Writer Bridgett Davis Discusses Mother’s Legacy in Memoir</h1>
<div class="post_byline">
<div class="post_byline_top">
by <a href="https://www.bcheights.com/archive.php/author/katherine-caniff/">Katherine Caniff</a> </div>
<div class="post_byline_bottom">
<div class="post_byline_bottom_left">
November 3, 2020&nbsp;&nbsp;&nbsp;&nbsp;Updated November 3, 2020 at 12:32 am </div>
<div class="post_byline_bottom_right">
<a href="https://www.facebook.com/share.php?u=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/&p[title]=Writer Bridgett Davis Discusses Mother’s Legacy in Memoir" target="_blank"><i class="m-a-icon-facebook"></i></a>
<a href="https://twitter.com/share?url=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/&amp;text=Writer Bridgett Davis Discusses Mother’s Legacy in Memoir" target="_blank"><i class="m-a-icon-twitter"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" target="_blank"><i class="m-a-icon-linkedin"></i></a>
<a href="https://web.whatsapp.com/send?text=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" target="_blank"><i class="m-a-icon-whatsapp"></i></a>
</div>
</div>
</div>
<span class="title-divider"></span>
<div class="entry-content">
<p>When author Bridgett M. Davis’ son asked her what kind of person his grandmother was, words initially failed her—so she immediately set off to write her mother’s story. Unwilling to leave whether the world would know the extraordinary woman her mother was up to chance, Davis recorded memories of her mother and her childhood in Detroit in her memoir, <em>The World According to Fannie Davis: My Mother’s Life in the Detroit Numbers</em>.&nbsp;</p>
<p>During October 21’s Lowell Humanities Series <a href="https://events.bc.edu/event/bridgett_m_davis_the_world_according_to_fannie_davis#.X5MqLvhKhR0">lecture</a>, moderated by English professor and journalism program director Angela Ards, the author discussed how she created the memoir, which was published in January of 2019, and the essential work the book does by sharing the story of a Black middle-class woman&#8217;s struggles and triumphs in Detroit.&nbsp;</p>
<p>Davis said the admiration she always felt toward her mother, Fannie, fueled her as she wrote about her life. Fannie Davis ran a numbers business out of their family home. Davis explained the numbers game referred to an illegal lottery, which can be traced back to the beginnings of colonial America. This lottery provided Black people with an opportunity to start their own businesses, as they were often excluded from the mainstream economy.&nbsp;</p>
<p>Growing up, Davis constantly heard her mother on the phone, collecting bets and growing her business—traits Davis admired as she noticed how Fannie provided her and her siblings with all they needed.&nbsp;</p>
<p>“She was the kind of mother that her own daughter would want to someday write a book about,” Davis said.</p>
<p>Moving to Detroit during the 1950s and 1960s framed Fannie Davis’ experiences. Attempting to escape the racism that was rampant in Tennessee during the years of the Jim Crow laws, Fannie Davis found herself encountering similar incidents in Detroit. The city’s racist policies left Fannie with only tiring service jobs and meager pay. Davis emphasized that her mother’s eventual success at her lottery business is one of many stories of Black people creating their own paths.&nbsp;</p>
<p>“My mother, Fannie, figured out how to do something that Black people have had to do for decades, if not centuries, in this country,” Davis said, “She made a way out of no way.”</p>
<p>As her mother’s business grew, Davis remembered the pride her mother must have felt by providing high-quality education and beautiful clothes for her children. Quoting from her book, Davis recalled the bright yellow shoes her mother bought for her and the books that Fannie filled her shelves with.&nbsp;</p>
<p>Davis portrayed her mother as a complex female character—someone who enjoyed treating herself to expensive garments but always helped other people in her community. Fannie also taught her daughter how to handle the unavoidable racism in the world, and how to demand respect from others.&nbsp;</p>
<p>Davis said her mother’s motto was “You’re as good as anyone, but better than no one.”</p>
<p>Ards joined the conversation by asking what compelled Davis to tell her mother’s story. Ards emphasized the rarity and importance of a character like Fannie, a successful and complex Black woman, in literature. In response to Ards, Davis shared that she no longer wanted to keep her mother’s life a secret, as she had done so for many years in order to avoid revealing the illicit nature of her mother’s work. She decided to celebrate her mother’s life and enduring legacy through her writing.&nbsp;</p>
<p>Davis began her career as a journalist, but she has expanded her craft over the years. Her many titles include novelist, essayist, teacher, filmmaker, and memoirist. When writing her book, her journalistic instincts drove her to relentlessly research the culture in Detroit, she said. She interviewed many people and dug through archival materials to learn about the illegal lottery in the city and her mother’s role as one of the few women in the numbers business.&nbsp;</p>
<p>“I don’t see any separation between those journalistic skills and my quest to be a writer,” Davis said about the intersection of the disciplines.&nbsp;</p>
<p>Ards brought attention to how Davis illustrated middle-class Black people in Detroit throughout the memoir. The author confirmed she wanted to celebrate this thriving population of Black people in the city that she grew up around that were rarely portrayed in literature. Davis’ memoir adds to the growing number of stories of people of color that are now being published.</p>
<p>“There are so many stories out there that are waiting to be told,” Davis said.&nbsp;</p>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
<div class="taglist">
<i class="fa fa-tag"></i> <a href="https://www.bcheights.com/tag/angela-ards/" rel="tag">angela ards</a> <a href="https://www.bcheights.com/tag/bridgett-davis/" rel="tag">bridgett davis</a> </div>
<div class="clear"></div>
</div>
<footer class="entry-tools">
<span>November 3, 2020</span>
<div class="share"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" target="_blank" class="facebook"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/share?text=Writer+Bridgett+Davis+Discusses+Mother%E2%80%99s+Legacy+in+Memoir&amp;url=https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" target="_blank" class="twitter"><i class="fa fa-twitter"></i></a>
<a href="https://pinterest.com/pin/create/button/?media=https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis.jpg&amp;description=Writer+Bridgett+Davis+Discusses+Mother%E2%80%99s+Legacy+in+Memoir&amp;url=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F" target="_blank" class="pinterest"><i class="fa fa-pinterest"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;title=Writer+Bridgett+Davis+Discusses+Mother%E2%80%99s+Legacy+in+Memoir&amp;source=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F&amp;url=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F" target="_blank" class="linkedin"><i class="fa fa-linkedin"></i></a>
</div>
</footer>
</div>
</article>

<div class="post_navi">
<div class="alignleft item"><i class="fa fa-angle-left"></i><a href="https://www.bcheights.com/2020/11/02/hafley-voting-syracuse-presser/" rel="prev">Hafley Prepares Eagles Both to Vote and to Take on Syracuse</a></div>
</div>
<section class="related-posts">
<h3 class="section-title">You may also like</h3>
<div class="grids">
<div class="item post">
<div class="thumbnail">
<a title="Angela Ards Uses &#8216;Fake News&#8217; to Teach Real Journalism at BC" href="https://www.bcheights.com/2017/09/25/angela-ards-fake-news/">
<img width="300" height="200" src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new-300x200.jpg" class="attachment-medium size-medium wp-post-image" alt="Angela Ards" loading="lazy" srcset="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new-300x200.jpg 300w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new-768x512.jpg 768w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new-1024x683.jpg 1024w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="136586" data-permalink="https://www.bcheights.com/2017/09/25/angela-ards-fake-news/img_5642-color-new/" data-orig-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new.jpg" data-orig-size="1200,800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS Rebel T6i&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1505736626&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;38&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.002&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Angela Ards" data-image-description="" data-medium-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new-300x200.jpg" data-large-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/09/03221640/IMG_5642-color-new-1024x683.jpg" /></a>
</div>
<header class="entry-header">
<h6><a href="https://www.bcheights.com/2017/09/25/angela-ards-fake-news/">Angela Ards Uses &#8216;Fake News&#8217; to Teach Real Journalism at BC</a></h6>
</header>
</div>
<div class="item post">
<div class="thumbnail">
<a title="Back to School Guide: Professors Worth Taking" href="https://www.bcheights.com/2017/08/30/back-to-school-guide-cool-professors/">
<img width="300" height="169" src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/08/03222227/IMG_6357-copy-2-300x169.jpg" class="attachment-medium size-medium wp-post-image" alt="cool professors" loading="lazy" srcset="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/08/03222227/IMG_6357-copy-2-300x169.jpg 300w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/08/03222227/IMG_6357-copy-2.jpg 678w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="135034" data-permalink="https://www.bcheights.com/2017/08/30/back-to-school-guide-cool-professors/img_6357-copy-2-2/" data-orig-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/08/03222227/IMG_6357-copy-2.jpg" data-orig-size="678,381" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 5s&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1391789773&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.12&quot;,&quot;iso&quot;:&quot;40&quot;,&quot;shutter_speed&quot;:&quot;0.000454545454545&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cool professors" data-image-description="" data-medium-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/08/03222227/IMG_6357-copy-2-300x169.jpg" data-large-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2017/08/03222227/IMG_6357-copy-2.jpg" /></a>
</div>
<header class="entry-header">
<h6><a href="https://www.bcheights.com/2017/08/30/back-to-school-guide-cool-professors/">Back to School Guide: Professors Worth Taking</a></h6>
</header>
</div>
<div class="clearfix"></div>
</div>
</section>


<p class="must-log-in">You must <a href="https://www.bcheights.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.bcheights.com%2F2020%2F11%2F03%2Fbridgett-davis-memoir-lecture%2F%23respond">log in</a> to post a comment.</p>
</div>
</div>

<aside id="sidebar" class="four columns omega">
<div id="adplugg-14" class="widget adplugg"><div class="adplugg-tag" data-adplugg-zone="article_sidebar"></div></div><div id="text-103" class="widget widget_text"><h6 class="widget_title">HEIGHTS NEWSLETTER</h6> <div class="textwidget"><div style="font-size: 120%; font-family: Georgia,Times, 'Times New Roman', serif;">
<span style="font-size: 120%;"><img loading="lazy" class="aligncenter wp-image-180282" src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/06/05191428/NEWSLETTERGRAPHICFORWEBSITE-01.png" alt="" width="241" height="185" srcset="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/06/05191428/NEWSLETTERGRAPHICFORWEBSITE-01.png 2253w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/06/05191428/NEWSLETTERGRAPHICFORWEBSITE-01-300x231.png 300w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/06/05191428/NEWSLETTERGRAPHICFORWEBSITE-01-1024x787.png 1024w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/06/05191428/NEWSLETTERGRAPHICFORWEBSITE-01-768x590.png 768w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/06/05191428/NEWSLETTERGRAPHICFORWEBSITE-01-1536x1181.png 1536w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/06/05191428/NEWSLETTERGRAPHICFORWEBSITE-01-2048x1574.png 2048w" sizes="(max-width: 241px) 100vw, 241px" /></span>
</div></div>
</div><div id="yikes_easy_mc_widget-2" class="widget widget_yikes_easy_mc_widget">
<section id="yikes-mailchimp-container-2" class="yikes-mailchimp-container yikes-mailchimp-container-2 ">
<form id="newsletter-sign-up-2" class="yikes-easy-mc-form yikes-easy-mc-form-2  " method="POST" data-attr-form-id="2">
<label for="yikes-easy-mc-form-2-EMAIL" class="EMAIL-label yikes-mailchimp-field-required ">

<span class="EMAIL-label">
Email Address </span>

<input id="yikes-easy-mc-form-2-EMAIL" name="EMAIL" placeholder="" class="yikes-easy-mc-email " required="required" type="email" value="">

</label>

<input type="hidden" name="yikes-mailchimp-honeypot" id="yikes-mailchimp-honeypot-2" value="">

<input type="hidden" name="yikes-mailchimp-associated-list-id" id="yikes-mailchimp-associated-list-id-2" value="cc66bd77da">

<input type="hidden" name="yikes-mailchimp-submitted-form" id="yikes-mailchimp-submitted-form-2" value="2">

<button type="submit" class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-2 btn btn-primary "> <span class="yikes-mailchimp-submit-button-span-text">Sign Up</span></button> 
<input type="hidden" id="yikes_easy_mc_new_subscriber_2" name="yikes_easy_mc_new_subscriber" value="afea45c986">
<input type="hidden" name="_wp_http_referer" value="/2020/11/03/bridgett-davis-memoir-lecture/" />
</form>

</section>
</div><div id="top-posts-9" class="widget widget_top-posts"><h6 class="widget_title">Top Stories</h6><ul> <li>
<a href="https://www.bcheights.com/2020/11/01/ariana-grande-positions/" class="bump-view" data-bump-view="tp">Ariana Grande’s &#039;Positions&#039; Falls Short of a Halloween Treat</a> </li>
<li>
<a href="https://www.bcheights.com/2020/11/01/ugbc-resolution-voting-holiday-override-veto/" class="bump-view" data-bump-view="tp">UGBC Asks BC to Cancel Classes on Election Day, Overriding Presidential Veto</a> </li>
<li>
<a href="https://www.bcheights.com/2020/11/02/boston-college-braces-for-2020-presidential-election/" class="bump-view" data-bump-view="tp">&quot;An Election Like No Other&quot;: Boston College Braces for 2020 Presidential Election</a> </li>
<li>
<a href="https://www.bcheights.com/2020/11/02/popular-frontism-in-the-age-of-trump/" class="bump-view" data-bump-view="tp">Leftist, Communists Debate Supporting Biden</a> </li>
<li>
<a href="https://www.bcheights.com/2020/11/01/covid-19-update-nov-1/" class="bump-view" data-bump-view="tp">Week Nine COVID-19 Positivity Rate Rises, Remains Below State and Local Rates</a> </li>
</ul></div><div id="search-11" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://www.bcheights.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> </aside>
</div> <div id="bottom_widget">
<div class="container">
<section class="four columns">
<div class="widget">
<h6 class="widget_title">RECENT POSTS</h6>
<ul class="post_list"><li class="post-list-184692"><a href="https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" class="thumbnail"><img src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/03003151/BridgettDavis-150x150.jpg" alt="Writer Bridgett Davis Discusses Mother’s Legacy in Memoir" /></a><a href="https://www.bcheights.com/2020/11/03/bridgett-davis-memoir-lecture/" class="post_title">Writer Bridgett Davis Discusses Mother’s Legacy in Memoir</a><p>November 3, 2020</p><div class="clear"></div></li><li class="post-list-184686"><a href="https://www.bcheights.com/2020/11/02/hafley-voting-syracuse-presser/" class="thumbnail"><img src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/02211554/JI0A0472-150x150.jpg" alt="Hafley Prepares Eagles Both to Vote and to Take on Syracuse" /></a><a href="https://www.bcheights.com/2020/11/02/hafley-voting-syracuse-presser/" class="post_title">Hafley Prepares Eagles Both to Vote and to Take on Syracuse</a><p>November 2, 2020</p><div class="clear"></div></li><li class="post-list-184683"><a href="https://www.bcheights.com/2020/11/02/new-caffe-nero-comes-to-newtonville/" class="thumbnail"><img src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/11/02182854/Caffe-Nero-online-150x150.jpg" alt="Caffe Nero Comes to Newtonville" /></a><a href="https://www.bcheights.com/2020/11/02/new-caffe-nero-comes-to-newtonville/" class="post_title">Caffe Nero Comes to Newtonville</a><p>November 2, 2020</p><div class="clear"></div></li><li class="post-list-184678"><a href="https://www.bcheights.com/2020/11/02/thumbs-up-thumbs-down-please-vote/" class="thumbnail"><img src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/10/05200758/Thumbs-up-thumbs-down-01-150x150.png" alt="Thumbs Up, Thumbs Down: Please Vote!" /></a><a href="https://www.bcheights.com/2020/11/02/thumbs-up-thumbs-down-please-vote/" class="post_title">Thumbs Up, Thumbs Down: Please Vote!</a><p>November 2, 2020</p><div class="clear"></div></li><li class="post-list-184673"><a href="https://www.bcheights.com/2020/11/02/ranked-choice-voting-on-massachusetts-ballot/" class="thumbnail"><img src="https://s3.amazonaws.com/photos.bcheights.com/wp-content/uploads/2020/02/03121457/AH1I9484_onlineform-150x150.jpg" alt="Ranked-Choice Voting on Massachusetts Ballot" /></a><a href="https://www.bcheights.com/2020/11/02/ranked-choice-voting-on-massachusetts-ballot/" class="post_title">Ranked-Choice Voting on Massachusetts Ballot</a><p>November 2, 2020</p><div class="clear"></div></li></ul> </div>
</section>
<section class="four columns">
<div id="text-115" class="widget widget_text"><h6 class="widget_title">CONTACT</h6> <div class="textwidget">The offices of <i>The Heights </i>are located on Boston College’s campus. You can find us at:
<div>The Heights
113 McElroy Commons
Chestnut Hill, MA 02467</div></div>
</div> </section>
<section class="four columns">
<div id="text-116" class="widget widget_text"><h6 class="widget_title">ABOUT</h6> <div class="textwidget">Established in 1919 as Boston College’s student newspaper, <i>The Heights </i>has been both editorially and financially independent from the University since 1971. <i>The Heights</i> serves the students, faculty, and staff of the Boston College community, as well as our neighbors in Chestnut Hill, Newton, and the Allston-Brighton area.
&nbsp;</div>
</div> </section>
<section class="four columns omega">
<div class="widget">
<h6 class="widget_title">THEMEVAN</h6>
<div class="textwidget">
<p>We are addicted to WordPress development and provide Easy to using & Shine Looking themes selling on ThemeForest.</p><p>Tel : (000) 456-7890<br />Email : <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="204d41494c60634f4d50414e596e414d450e434f4d">[email&#160;protected]</a><br />Address : NO 86 XX ROAD, XCITY, XCOUNTRY.</p>
</div>
</div>
</section>
</div>
</div> 

<footer id="footer">
<div class="container">
<div class="copyright eight columns">
Copyright &copy; 2020 <a href="https://www.bcheights.com/" title="The Heights">The Heights</a>. All rights reserved.
</div>
<div class="footer_menu eight columns">
</div>
</div>
</footer>

<div id="popup_window" class="popup_content">
<a href="javascript:void(0)" class="close_popup"><i class="fa fa-close"></i></a>
<div id="popup_search" class="popup_content">
<h3>Searching</h3>
<div class="content container">
<form action="https://www.bcheights.com/" method="get" name="searchform" class="popup_form">
<div class="eight columns alpha">
<input type="text" name="s" class="u-full-width" placeholder="Keyword" />
</div>
<div class="four columns alpha omega">
<input type="submit" name="search_button" class="button-primary" value="Search" />
</div>
</form>
</div>
</div>
</div>
<div class="page_mask"></div>
</div>
<a href="javascript:void(0);" class="up_btn" id="backtoTop"><i class="fa fa-arrow-up"></i></a>
<style>
#ot-ccpa-banner {
	font-family: "Open Sans"; 
	margin: 0; 
	padding: 0;
	position: 
	fixed;
	bottom: 0;
	left: 1%;
	max-width: 400px;
	background-color: transparent;
	z-index: 9999;
	margin-right: 20px; 
}
#ot-ccpa-banner .ot-ccpa-icon {
	position: absolute; 
	bottom: 10px; 
	left: 0; 
	width: 50px;
	line-height: 15px;
	cursor: pointer;
	padding: 8px;
	background-color: #6699CC;
	border-radius: 10px; 
	height: 50px;
	display: flex; 
	justify-content: center; 
	align-items: center;
}
#ot-ccpa-banner .ot-ccpa-icon img{ 
	width: 100%; 
}

.CCPAFloatRight{ 
	right: 1% ; 
	left: auto !important; 
}
.ot-ccpa-optout__button--light{
	display: none !important}
</style>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
jQuery(function(){
    jQuery("#ot-ccpa-banner,#otCCPAdoNotSellLink,.ot-ccpa-optout__button").click(function(){
        jQuery("#ot-ccpa-banner").toggle();
    });
    jQuery(document).on('click','.ot-ccpa-optout__buttons__close, .ot-ccpa-optout__confirm',function(){
        setTimeout(function(){
            if(jQuery(".ot-ccpa-icon").hasClass("enableicon")){ jQuery("#ot-ccpa-banner").show(); }
        }, 300);
    });
});
</script>
<style type="text/css">#otCCPAdoNotSellLink{ display: none !important; }</style>
<script>
    var otCcpaScript = document.createElement('script'),
    script1 = document.getElementsByTagName('script')[0];
    otCcpaScript.src = 'https://cookie-cdn.cookiepro.com/ccpa-optout-solution/v1/ccpa-optout.js';
    otCcpaScript.async = true;
    otCcpaScript.type = 'text/javascript';
    script1.parentNode.insertBefore(otCcpaScript, script1);
    otCcpaData = {
		isButtonEnabled: null,
		isLinkEnabled: null,
		headerBackgroundcolor: null,
		headerTextcolor: null,
		buttonBackgroundColor: null,
		buttonTextColor: null,
		popup_main_title: "",
		// Policy Settings
		PrivacyPolicyMessage: "",
		linkURL: null,
		linkText: "",
		// Email Settings
		isEmailEnabled: false,
		emailAddress: null,
		// Phone Settings
		isPhoneEnabled: false,
		phoneNumber: null,
		// Form Link settings
		form_enable: false,
		form_link_text: "",
		form_link_url: null,
		// GooglePersonalize settings
		isGooglePersonalizeEnabled: "",
		googleConfirmationTitle: "",
		googleConfirmationMessage: "",
		confirmbutton: null,
		frameworks: "",
		isLSPAenable: false,
		// Display position
		DisplayPosition: null,
		location: "All"    }
    window.otccpaooSettings = {
	    layout: {
		    dialogueLocation: otCcpaData.DisplayPosition,
		    primaryColor: otCcpaData.headerBackgroundcolor,
		    secondaryColor: otCcpaData.headerTextcolor,
            button: {
                primary: otCcpaData.buttonBackgroundColor,
                secondary: otCcpaData.buttonTextColor,
            }		    
	    },
	    dialogue: {
			email: {
			    display: otCcpaData.isEmailEnabled,
			    title: otCcpaData.emailAddress,
			    url: "mailto:" + otCcpaData.emailAddress,
		    },
            lspa: {
                accepted: otCcpaData.isLSPAenable,
            },
            phone: {
                display: otCcpaData.isPhoneEnabled,
                title: otCcpaData.phoneNumber,
                url: "tel:" + otCcpaData.phoneNumber,
            },            		    
		    dsar: {
			    display: otCcpaData.form_enable,
			    title: otCcpaData.form_link_text,
			    url: otCcpaData.form_link_url,
		    },
		    intro: {
			    title: otCcpaData.popup_main_title,
			    description: otCcpaData.PrivacyPolicyMessage,
		    },
		    privacyPolicy: {
			    title: otCcpaData.linkText,
			    url: otCcpaData.linkURL,
		    },
		    optOut: {
			    title: otCcpaData.googleConfirmationTitle,
			    description: otCcpaData.googleConfirmationMessage,
			    frameworks: [otCcpaData.frameworks, otCcpaData.isGooglePersonalizeEnabled],
		    },
		    location: otCcpaData.location,
		    confirmation: {
			    text: otCcpaData.confirmbutton,
		    },
	    }
    }; 
</script>
<div id="ot-ccpa-banner" class="" style="display:none;" data-ot-ccpa-opt-out="buttonicon">
<div class="ot-ccpa-icon  " style="display:none;background-color: ">
<a href="javascript:void(0);"><img src="https://www.bcheights.com/wp-content/plugins/cookiepro-ccpa/assets/images/icon.png" alt="Popup Button" title="CookiePro Do Not Sell" /></a>
</div>
</div>
<script type="text/javascript">
var sbiajaxurl = "https://www.bcheights.com/wp-admin/admin-ajax.php";
</script>
<footer id="bb-footer-container-footer" class="bb-footer-container">
<div id="bb-footer-inside-footer" class="bb-footer-inside">
<div class="vc_row wpb_row vc_row-fluid"><div class="wpb_column vc_column_container vc_col-sm-3"><div class="vc_column-inner"><div class="wpb_wrapper">
<div class="wpb_single_image wpb_content_element vc_align_left">
<figure class="wpb_wrapper vc_figure">
<a href="http://bcheights.com" target="_self" class="vc_single_image-wrapper   vc_box_border_grey"><img width="300" height="64" src="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-300x64.png" class="vc_single_image-img attachment-medium" alt="" loading="lazy" srcset="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-300x64.png 300w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-1024x219.png 1024w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-768x165.png 768w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-1536x329.png 1536w, https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-2048x439.png 2048w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="170520" data-permalink="https://www.bcheights.com/compromise2/" data-orig-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2.png" data-orig-size="2100,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="compromise2" data-image-description="" data-medium-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-300x64.png" data-large-file="https://s3.amazonaws.com/heights-photos/wp-content/uploads/2020/04/05191511/compromise2-1024x219.png" /></a>
</figure>
</div>
</div></div></div><div class="wpb_column vc_column_container vc_col-sm-3"><div class="vc_column-inner"><div class="wpb_wrapper">
<div class="wpb_text_column wpb_content_element ">
<div class="wpb_wrapper">
<p style="text-align: center;"><span style="font-size: 10pt;"><a href="http://bcheights.com/news">NEWS</a></span><br />
<span style="font-size: 10pt;"><a href="http://bcheights.com/sports">SPORTS</a></span><br />
<span style="font-size: 10pt;"><a href="http://bcheights.com/arts">ARTS</a></span><br />
<span style="font-size: 10pt;"><a href="http://magazine.bcheights.com">MAGAZINE</a></span><br />
<span style="font-size: 10pt;"><a href="http://bcheights.com/metro">METRO</a></span><br />
<span style="font-size: 10pt;"><a href="http://bcheights.com/opinions">OPINIONS</a></span><br />
<span style="font-size: 10pt;"><a href="http://bcheights.com/photo">PHOTO</a></span></p>
</div>
</div>
</div></div></div><div class="wpb_column vc_column_container vc_col-sm-3"><div class="vc_column-inner"><div class="wpb_wrapper">
<div class="wpb_text_column wpb_content_element ">
<div class="wpb_wrapper">
<p style="text-align: center;"><span style="font-size: 10pt;"><a href="http://bcheights.com/contact"><span style="text-decoration: underline;">Contact</span></a></span></p>
<p style="text-align: center;"><span style="font-size: 10pt;"><a href="http://bcheights.com/join">JOIN THE HEIGHTS</a></span><br />
<span style="font-size: 10pt;"><a href="http://bcheights.com/subscribe">SUBSCRIBE TO PRINT</a><br />
<a style="font-size: 10pt;" href="http://bcheights.com/advertise">ADVERTISE</a><br />
</span><span style="font-size: 10pt;"><a href="http://bcheights.com/newsletter">NEWSLETTER</a></span><br />
<a href="http://bcheights.com/tips"><span style="font-size: 10pt;">TIPS AND CORRECTIONS</span></a><br />
<span style="font-size: 10pt;"><a href="http://support.bcheights.com">DONATE</a></span></p>
</div>
</div>
</div></div></div><div class="wpb_column vc_column_container vc_col-sm-3"><div class="vc_column-inner"><div class="wpb_wrapper">
<div class="wpb_text_column wpb_content_element ">
<div class="wpb_wrapper">
<p style="text-align: center;"><span style="font-size: 10pt;"><a href="http://bcheights.com/about-us"><span style="text-decoration: underline;">About</span></a></span></p>
<p style="text-align: center;"><span style="font-size: 10pt;"><a href="http://bcheights.com/staff">STAFF</a></span><br />
<a href="http://bcheights.com/editorial-policies"><span style="font-size: 10pt;">SUBMIT TO US / </span><span style="font-size: 10pt;">EDITORIAL POLICIES</span></a><br />
<span style="font-size: 10pt;"><a href="http://bcheights.com/archive">ARCHIVE</a></span></p>
</div>
</div>
</div></div></div></div> </div>
</footer>
<link rel='stylesheet' id='yikes-inc-easy-mailchimp-public-styles-css' href='https://www.bcheights.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/css/yikes-inc-easy-mailchimp-extender-public.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='otCCPAStylegooglefont-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700&#038;display=swap&#038;ver=1.0' type='text/css' media='' />
<link rel='stylesheet' id='js_composer_front-css' href='https://www.bcheights.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.4.1' type='text/css' media='all' />
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.bcheights.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2' id='contact-form-7-js'></script>
<script type='text/javascript' id='molongui-authorship-js-extra'>
/* <![CDATA[ */
var molongui_authorship = {"byline_prefix":"","byline_suffix":"","byline_separator":", ","byline_last_separator":" and ","byline_link_title":"View all posts by","byline_dom_tree":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/molongui-authorship-pro/public/js/molongui-authorship-pro.37db.min.js?ver=1.0.7' id='molongui-authorship-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/themes/citynews/assets/js/jquery.sticky.js' id='sticky-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/themes/citynews/assets/js/jquery.easing.min.js' id='easing-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/themes/citynews/build/citynews.min.js' id='citynews-js'></script>
<script type='text/javascript' id='citynews-js-after'>
			   var comment_title="COMMENT ON THIS POST";
			   var temperature_unit="f";
			   var clientIP = "107.23.218.4";
			   var ipinfodb_api = "612e1c7e08cb39a7d1562c01763bbaf22146dab8dcabf4298eea56ba8292c253";
			   var template_url = "https://www.bcheights.com/wp-content/themes/citynews";
		   
</script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/bb_footer_builder//assets/js/script.js?ver=1.8.9' id='bbfb-builder-js'></script>
<script type='text/javascript' id='twitter-wjs-js-extra'>
/* <![CDATA[ */
window.twttr=(function(w){t=w.twttr||{};t._e=[];t.ready=function(f){t._e.push(f);};return t;}(window));
/* ]]> */
</script>
<script type="text/javascript" id="twitter-wjs" async defer src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-includes/js/comment-reply.min.js?ver=5.5.3' id='comment-reply-js'></script>
<script type='text/javascript' id='yikes-easy-mc-ajax-js-extra'>
/* <![CDATA[ */
var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/www.bcheights.com\/wp-admin\/admin-ajax.php","page_data":"184692","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/www.bcheights.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/www.bcheights.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"23a2cd19f5","feedback_message_placement":"before"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=6.7.0' id='yikes-easy-mc-ajax-js'></script>
<script type='text/javascript' id='form-submission-helpers-js-extra'>
/* <![CDATA[ */
var form_submission_helpers = {"ajax_url":"https:\/\/www.bcheights.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/www.bcheights.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"184692"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=6.7.0' id='form-submission-helpers-js'></script>
<script type='text/javascript' src='https://www.bcheights.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.4.1' id='wpb_composer_front_js-js'></script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-202045.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'69550814',post:'184692',tz:'-5',srv:'www.bcheights.com'} ]);
	_stq.push([ 'clickTrackerInit', '69550814', '184692' ]);
</script>
</body>
</html>